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Preface

Profile

Before You Begin This Course

Before you begin this course, you should have the following qualifications:

• Thorough knowledge of setting up items and bills of material as well as
the typical business requirements for processing engineering changes.

• Working experience with Oracle Engineering and Oracle Bills Of
Material.

Prerequisites

• R11i – Setting Up and Implementing Engineering.

How This Course Is Organized

R11i – Managing Engineering Change Orders is an instructor-led course featuring
lecture and hands-on exercises.  Online demonstrations and written practice
sessions reinforce the concepts and skills introduced.
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Related Publications

Oracle Publications

Title Part Number

None

Additional Publications

• System release bulletins

• Installation and user’s guides

• read.me files

• Oracle Magazine
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Typographic Conventions

Typographic Conventions in Text

Convention Element Example
Bold italic Glossary term (if

there is a glossary)
The algorithm inserts the new key.

Caps and
lowercase

Buttons,
check boxes,
triggers,
windows

Click the Executable button.
Select the Can’t Delete Card check box.
Assign a When-Validate-Item trigger to the
ORD block.
Open the Master Schedule window.

Courier new,
case sensitive
(default is
lowercase)

Code output,
directory names,
filenames,
passwords,
pathnames,
URLs,
user input,
usernames

Code output: debug.set (‘I”, 300);
Directory: bin (DOS), $FMHOME (UNIX)
Filename: Locate the init.ora file.
Password: User tiger as your password.
Pathname: Open c:\my_docs\projects
URL: Go to http://www.oracle.com
User input: Enter 300
Username: Log on as scott

Initial cap Graphics labels
(unless the term is a
proper noun)

Customer address (but Oracle Payables)

Italic Emphasized words
and phrases,
titles of books and
courses,
variables

Do not save changes to the database.
For further information, see Oracle7 Server
SQL Language Reference Manual.
Enter user_id@us.oracle.com,
where user_id is the name of the user.

Quotation
marks

Interface elements
with long names
that have only
initial caps;
lesson and chapter
titles in cross-
references

Select “Include a reusable module component”
and click Finish.

This subject is covered in Unit II, Lesson 3,
“Working with Objects.”

Uppercase SQL column
names, commands,
functions, schemas,
table names

Use the SELECT command to view
information stored in the LAST_NAME
column of the EMP table.

Convention Element Example
Arrow Menu paths Select File—> Save.
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Brackets Key names Press [Enter].

Commas Key sequences Press and release keys one at a time:
[Alternate], [F], [D]

Plus signs Key combinations Press and hold these keys simultaneously:
[Ctrl]+[Alt]+[Del]

Typographic Conventions in Code

Convention Element Example
Caps and
lowercase

Oracle Forms
triggers

When-Validate-Item

Lowercase Column names,
table names

SELECT last_name
FROM s_emp;

Passwords DROP USER scott
IDENTIFIED BY tiger;

PL/SQL objects OG_ACTIVATE_LAYER
(OG_GET_LAYER

(‘prod_pie_layer’))

Lowercase
italic

Syntax variables CREATE ROLE role

Uppercase SQL commands and
functions

SELECT userid
FROM emp;

Typographic Conventions in Navigation Paths

This course uses simplified navigation paths, such as the following example, to
direct you through Oracle Applications.

(N) Invoice > Entry > Invoice Batches Summary (M) Query > Find (B) Approve

This simplified path translates to the following:

1. (N) From the Navigator window, select Invoice > Entry > Invoice Batches
Summary.

2. (M) From the menu, select Query > Find.

3. (B) Click the Approve button.

Notations :

(N) = Navigator

(M) = Menu

(T) = Tab
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(I) = Icon

(H) = Hyperlink

(B) = Button

Typographical Conventions in Help System Paths

This course uses a “navigation path” convention to represent actions you perform
to find pertinent information in the Oracle Applications Help System.

The following help navigation path, for example—

(Help) General Ledger > Journals > Enter Journals

—represents the following sequence of actions:

1. In the navigation frame of the help system window, expand the General
Ledger entry.

2. Under the General Ledger entry, expand Journals.

3. Under Journals, select Enter Journals.

4. Review the Enter Journals topic that appears in the document frame of the
help system window.

Getting Help

Oracle Applications provides you with a complete online help facility.

Whenever you need assistance, simply choose an item from the Help menu to
pinpoint the type of information you want.

To display help for a current window:

1. Choose Window Help from the Help menu, click the Help button on the
toolbar, or hold down the Control key and type 'h'.

A web browser window appears, containing search and navigation frames on
the left, and a frame that displays help documents on the right.

The document frame provides information on the window containing the
cursor. The navigation frame displays the top-level topics for your
responsibility, arranged in a tree control.

2. If the document frame contains a list of topics associated with the window,
click on a topic of interest to display more detailed information.
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3. You can navigate to other topics of interest in the help system, or choose
Close from your web browser's File menu to close help.

Searching for Help

You can perform a search to find the Oracle Applications help information you
want. Simply enter your query in the text field located in the top-left frame of the
browser window when viewing help, then click the adjacent Find button.

A list of titles, ranked by relevance and linked to the documents in question, is
returned from your search in the right-hand document frame. Click on whichever
title seems to best answer your needs to display the complete document in this
frame. If the document doesn't fully answer your questions, use your browser's
Back button to return to the list of titles and try another.
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R11i - Managing Engineering Change
Orders

R11i - Managing Engineering Change
Orders
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ObjectivesObjectives

• After completing this lesson, you should be able
to do the following:
– Create engineering change orders
– Recognize the effects of engineering change

orders on bills of material
– Approve, schedule, and implement

engineering change orders
– Understand the new ECO Business Object

Interface

• After completing this lesson, you should be able
to do the following:
– Create engineering change orders
– Recognize the effects of engineering change

orders on bills of material
– Approve, schedule, and implement

engineering change orders
– Understand the new ECO Business Object

Interface
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AgendaAgenda

• Overview of Engineering Change Orders
• Engineering Change Order Life Cycle
• Engineering Change Order Business Object

Interface
• Summary
• Practice

• Overview of Engineering Change Orders
• Engineering Change Order Life Cycle
• Engineering Change Order Business Object

Interface
• Summary
• Practice
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Lesson 1:
Overview of Engineering Change Orders

Lesson 1:
Overview of Engineering Change Orders

• Overview of Engineering Change Orders
• Engineering Change Order Life Cycle
• Engineering Change Order Business Object

Interface
• Summary
• Practice

• Overview of Engineering Change Orders
• Engineering Change Order Life Cycle
• Engineering Change Order Business Object

Interface
• Summary
• Practice
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– An engineering change order (ECO) is an order
to change bills of material.

– An engineering change order cannot be used
to change routings.

– You can control the engineering change order
approval process by using Oracle Workflow.

– You can track the components being
discontinued, the new components being
added, and their effectivity dates.

– You can also enter any information on
substitution components.

– An engineering change order (ECO) is an order
to change bills of material.

– An engineering change order cannot be used
to change routings.

– You can control the engineering change order
approval process by using Oracle Workflow.

– You can track the components being
discontinued, the new components being
added, and their effectivity dates.

– You can also enter any information on
substitution components.

Help: Oracle Manufacturing Applications > Oracle Engineering >
Engineering Change Orders > Overview

… Engineering Change Orders >  ECOs on Items and Bills
… Engineering Change Orders > ECO Access Control
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Engineering Change OrdersEngineering Change Orders

EngineeringEngineering
changechange
orderorder

EEDD

BB CC

AA

MMDD

BB CC

AA
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Engineering Change OrdersEngineering Change Orders

• An engineering change order (ECO) is an order to
change bills of material to add, change and delete
components.

• You cannot use an ECO to change routings.
• ECO’s can be used to change both engineering

and manufacturing bills of material.
• ECO’s can specify changes to one or more revised

items.

• An engineering change order (ECO) is an order to
change bills of material to add, change and delete
components.

• You cannot use an ECO to change routings.
• ECO’s can be used to change both engineering

and manufacturing bills of material.
• ECO’s can specify changes to one or more revised

items.
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Engineering Change Orders
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Engineering Change OrdersEngineering Change Orders

• ECO’s can be subjected to a review process,
managed with either Oracle Engineering or Oracle
Workflow.

• When implementing the ECO, you can force the
ECO to increment the bill of material revision when
it changes the revised item.

• Bills of material can be changed without ECO’s
using the Bills of Material Form.  Or personal
profiles can be set to prohibit direct updates
without an ECO.

• ECO’s can be subjected to a review process,
managed with either Oracle Engineering or Oracle
Workflow.

• When implementing the ECO, you can force the
ECO to increment the bill of material revision when
it changes the revised item.

• Bills of material can be changed without ECO’s
using the Bills of Material Form.  Or personal
profiles can be set to prohibit direct updates
without an ECO.
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Lesson 2:
Engineering Change Order Life Cycle

Lesson 2:
Engineering Change Order Life Cycle

• Overview of Engineering Change Orders
• Engineering Change Order Life Cycle
• Engineering Change Order Business Object

Interface
• Summary
• Practice

• Overview of Engineering Change Orders
• Engineering Change Order Life Cycle
• Engineering Change Order Business Object

Interface
• Summary
• Practice
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ECO Life CycleECO Life Cycle

• When processing ECO’s you typically follow a set
pattern of action.

• These actions correspond to the ECO revised item
statuses and ECO approval statuses.

• ECO revised item status refers to the overall status
of the ECO and to the individual status of each
revised item on the ECO.

• ECO approval status refers to the process of
requesting and obtaining approval for the ECO
from a list of approvers.

• When processing ECO’s you typically follow a set
pattern of action.

• These actions correspond to the ECO revised item
statuses and ECO approval statuses.

• ECO revised item status refers to the overall status
of the ECO and to the individual status of each
revised item on the ECO.

• ECO approval status refers to the process of
requesting and obtaining approval for the ECO
from a list of approvers.

Help: Oracle Manufacturing Applications > Oracle Engineering >
Engineering Change Orders > ECO Life Cycle
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ECO StatusesECO Statuses

EE

CCBB

AA

DD MM

Removing one item from a bill and replacing it with another.Removing one item from a bill and replacing it with another.Removing one item from a bill and replacing it with another.
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ECO StatusesECO Statuses

• ECO Approval Statuses
– Not Ready - You are not ready to ask for

approval
– Ready to Approve - You are ready to ask the

approvers to review
– Approval Requested - Approvers have been

asked to review
– Approved - The decision has been made to

approve the ECO
– Rejected - The decision has been made to

reject the ECO
– Processing Error - An error occurred in the

workflow approval process

• ECO Approval Statuses
– Not Ready - You are not ready to ask for

approval
– Ready to Approve - You are ready to ask the

approvers to review
– Approval Requested - Approvers have been

asked to review
– Approved - The decision has been made to

approve the ECO
– Rejected - The decision has been made to

reject the ECO
– Processing Error - An error occurred in the

workflow approval process

Help: Oracle Manufacturing Applications > Oracle Engineering >
Engineering Change Orders > ECO Statuses

… Engineering Change Orders > ECO Approval Process > 
ECO Approval Statuses



Copyright © Oracle Corporation, 2000. All rights reserved.

R11i - Managing Engineering Change Orders
Chapter 1 - Page 14

ECO Statuses

Copyright  Oracle Corporation, 2000. All rights reserved.
®

ECO StatusesECO Statuses

• ECO Revised Item Statuses
– Open - You are preparing the information
– Release - You can manually implement the

change
– Schedule - The implementation concurrent

process implements the change
– Implement - You have successfully changed

the bill of material
– Hold - You have temporarily decided not to

implement a Released or Scheduled change
– Cancel - you have permanently decided not to

implement the change

• ECO Revised Item Statuses
– Open - You are preparing the information
– Release - You can manually implement the

change
– Schedule - The implementation concurrent

process implements the change
– Implement - You have successfully changed

the bill of material
– Hold - You have temporarily decided not to

implement a Released or Scheduled change
– Cancel - you have permanently decided not to

implement the change

Help: Oracle Manufacturing Applications > Oracle Engineering >
Engineering Change Orders > ECO Revised Item Statuses
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ECO Life Cycle - without ApprovalECO Life Cycle - without Approval

To implement ECO’s without an approval process:
• Enter the change information

– ECO approval status = Approved
– ECO revised item status = Open

• Implement the change
– ECO approval status = Approved
– ECO revised item status = Released or

Scheduled (for manual or auto
implementation)

• After the change is completed
– ECO approval status = Approved
– ECO revised item status = Implemented

To implement ECO’s without an approval process:
• Enter the change information

– ECO approval status = Approved
– ECO revised item status = Open

• Implement the change
– ECO approval status = Approved
– ECO revised item status = Released or

Scheduled (for manual or auto
implementation)

• After the change is completed
– ECO approval status = Approved
– ECO revised item status = Implemented

Help: Oracle Manufacturing Applications > Oracle Engineering >
Engineering Change Orders > ECO Approval Process > ECO
Approvals
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ECO Life Cycle
without Approval
ECO Life Cycle

without Approval

ImplementedImplemented

OpenOpen

ReleasedReleased ScheduledScheduled
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ECO Life Cycle - with ApprovalECO Life Cycle - with Approval
To implement ECO’s with an approval process:
• Enter the change information

– ECO approval status = Not Ready
– ECO revised item status = Open

• Prepare the change information for review
– ECO approval status = Ready to Approve
– ECO revised item status = Open

• Send the information to the approvers
– ECO approval status = Approval Requested
– ECO revised item status = Open

• Change is not approved
– ECO approval status = Rejected

To implement ECO’s with an approval process:
• Enter the change information

– ECO approval status = Not Ready
– ECO revised item status = Open

• Prepare the change information for review
– ECO approval status = Ready to Approve
– ECO revised item status = Open

• Send the information to the approvers
– ECO approval status = Approval Requested
– ECO revised item status = Open

• Change is not approved
– ECO approval status = Rejected
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ECO Life Cycle - with ApprovalECO Life Cycle - with Approval
Continued:

– ECO revised item status = Canceled
• Change is approved

– ECO approval status = Approved
– ECO revised item status = Open

• Implement the approved change
– ECO approval status = Approved
– ECO revised item status = Released or

Scheduled (for manual or auto
implementation)

• After the approved change is completed
– ECO approval status = Approved
– ECO revised item status = Implemented

Continued:
– ECO revised item status = Canceled

• Change is approved
– ECO approval status = Approved
– ECO revised item status = Open

• Implement the approved change
– ECO approval status = Approved
– ECO revised item status = Released or

Scheduled (for manual or auto
implementation)

• After the approved change is completed
– ECO approval status = Approved
– ECO revised item status = Implemented
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ECO Life Cycle - with ApprovalECO Life Cycle - with Approval

OpenOpen

ReleasedReleased ScheduledScheduled

ImplementedImplemented

Ready for
Approval

Ready for
Approval

Approval
Requested
Approval

Requested

ApprovedApprovedRejectedRejected
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ECO Approval: Oracle EngineeringECO Approval: Oracle Engineering

OracleOracle
EngineeringEngineering

EngineeringEngineering
Change OrderChange Order

Approved!Approved!

OracleOracle
EngineeringEngineering

OracleOracle
EngineeringEngineering
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ECO Approval: Oracle EngineeringECO Approval: Oracle Engineering

Managing the approval process using Engineering:
• Setup the approval process

– Create approval lists
– Assign an approval list to the ECO
– Assign an ECO change type to the ECO (one not

associated with an Oracle Workflow)
• The Oracle Engineering approval process steps

– Set ECO approval status to: Approval Requested
– Oracle Alert sends email to the reviewers
– Each approver responds: approved/rejected
– The responses are reviewed and the ECO

approval status is set to Approved or Rejected

Managing the approval process using Engineering:
• Setup the approval process

– Create approval lists
– Assign an approval list to the ECO
– Assign an ECO change type to the ECO (one not

associated with an Oracle Workflow)
• The Oracle Engineering approval process steps

– Set ECO approval status to: Approval Requested
– Oracle Alert sends email to the reviewers
– Each approver responds: approved/rejected
– The responses are reviewed and the ECO

approval status is set to Approved or Rejected

Help: Oracle Manufacturing Applications > Oracle Engineering >
Engineering Change Orders > ECO Approval Process > Defining ECO
Approval Lists
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ECO Approval: Oracle WorkflowECO Approval: Oracle Workflow

OracleOracle
Work FlowWork Flow

OracleOracle
EngineeringEngineering

EngineeringEngineering
Change OrderChange Order

Approved!Approved!

OracleOracle
EngineeringEngineering
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ECO Approval: Oracle WorkflowECO Approval: Oracle Workflow

Managing the approval process using Workflow:
• Setup the workflow approval process

– Create a workflow or use a seeded workflow
for approval with processes to perform actions
and notifications to contact employees for
decisions

– Assign an approvers list as a ‘role’ to the
workflow notification activity

– Assign the workflow to an ECO change type
– Assign the ECO change type to the ECO

Managing the approval process using Workflow:
• Setup the workflow approval process

– Create a workflow or use a seeded workflow
for approval with processes to perform actions
and notifications to contact employees for
decisions

– Assign an approvers list as a ‘role’ to the
workflow notification activity

– Assign the workflow to an ECO change type
– Assign the ECO change type to the ECO

Help: Oracle Manufacturing Applications > Oracle Engineering >
Engineering Change Orders > ECO Approval Process > Workflow for
ECO Approvals
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ECO Approval: Oracle WorkflowECO Approval: Oracle Workflow

Continued:
• The Oracle Workflow approval process steps

– Choose submit on the Engineering Change
Orders form

– The workflow notifies all employees in the role
– Each approver responds: approved/rejected
– Oracle Workflow tabulates the responses,

makes an approval decision, performs follow
up activities and returns control to Oracle
Engineering.

– If an error occurs the ECO approval status
becomes: Processing Error

Continued:
• The Oracle Workflow approval process steps

– Choose submit on the Engineering Change
Orders form

– The workflow notifies all employees in the role
– Each approver responds: approved/rejected
– Oracle Workflow tabulates the responses,

makes an approval decision, performs follow
up activities and returns control to Oracle
Engineering.

– If an error occurs the ECO approval status
becomes: Processing Error
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ECO Approval: Oracle WorkflowECO Approval: Oracle Workflow

For example the standard approval processing
workflow delivered in Oracle Engineering:
• Requires unanimous approval from the reviewers

to approve the ECO
• Sets MRP Active to selected or clear
• Sets the ECO approval status to Approved or

Rejected

For example the standard approval processing
workflow delivered in Oracle Engineering:
• Requires unanimous approval from the reviewers

to approve the ECO
• Sets MRP Active to selected or clear
• Sets the ECO approval status to Approved or

Rejected
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ECO Approval: Oracle WorkflowECO Approval: Oracle Workflow

Get ECO
Attributes

Set MRP
to

Inactive

Set MRP
to

Active

Get
Marketing
Approval

Approve
ECO

Reject
ECO

Get ECO
Committee
Approval

ApproveApprove YesYes

NoNo

RejectReject
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Lesson 3:
Engineering Change Order Business

Objects Interface

Lesson 3:
Engineering Change Order Business

Objects Interface

• Overview of Engineering Change Orders
• Engineering Change Order Life Cycle
• Engineering Change Order Business

Object Interface
• Summary
• Practice

• Overview of Engineering Change Orders
• Engineering Change Order Life Cycle
• Engineering Change Order Business

Object Interface
• Summary
• Practice
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ECO Business Object Interface OverviewECO Business Object Interface Overview

• Oracle Engineering enables collaborative product
design with your suppliers and customers.
Release 11i improves the transfer of information
with trading partners by incorporating the ECO
Business Object interface.

• Using the ECO Business Object interface, you can
simplify your access to Oracle Engineering ECOs
through a common, flexible, and robust interface
to meet your mission-critical business needs.

• Oracle Engineering enables collaborative product
design with your suppliers and customers.
Release 11i improves the transfer of information
with trading partners by incorporating the ECO
Business Object interface.

• Using the ECO Business Object interface, you can
simplify your access to Oracle Engineering ECOs
through a common, flexible, and robust interface
to meet your mission-critical business needs.

Help: Oracle Manufacturing Applications > Oracle Engineering > New
Features in This Release
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Importing ECOs

• You can quickly import ECOs by using the new
ECO Business Object interface from any external
system, including the Product Data Management
(PDM) system. Validation of all ECO information
during import clearly identifies change problems,
enabling the appropriate decision-makers to
resolve errors.

Importing ECOs

• You can quickly import ECOs by using the new
ECO Business Object interface from any external
system, including the Product Data Management
(PDM) system. Validation of all ECO information
during import clearly identifies change problems,
enabling the appropriate decision-makers to
resolve errors.
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Updating and Deleting ECOs

• You can also use the ECO Business Object
interface to update and delete existing ECO
information.

Updating and Deleting ECOs

• You can also use the ECO Business Object
interface to update and delete existing ECO
information.
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• Common, flexible, and robust
• Import capabilities to create, update, delete
• Synchronous—not batch API
• Validates change information
• Provides error messages

• Common, flexible, and robust
• Import capabilities to create, update, delete
• Synchronous—not batch API
• Validates change information
• Provides error messages

Oracle
Forms

Outside
systems

ECO
Business
object 

Interface

ECO
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• You should now be able to do the following:
– Create engineering change orders
– Recognize the effects of engineering change

orders on bills of material
– Approve, schedule, and implement

engineering change orders
– Understand the ECO business objects

interface

• You should now be able to do the following:
– Create engineering change orders
– Recognize the effects of engineering change

orders on bills of material
– Approve, schedule, and implement

engineering change orders
– Understand the ECO business objects

interface
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– Creating an ECO
– Reviewing changes
– Comparing current BOM and pending BOM
– Rescheduling the ECO
– Reviewing effects of pending changes

– Creating an ECO
– Reviewing changes
– Comparing current BOM and pending BOM
– Rescheduling the ECO
– Reviewing effects of pending changes
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– Approving engineering change orders with
Oracle Workflow

– Attaching a workflow process to the change
type

– Approving an ECO
– Releasing an ECO
– Manually implementing the ECO

– Approving engineering change orders with
Oracle Workflow

– Attaching a workflow process to the change
type

– Approving an ECO
– Releasing an ECO
– Manually implementing the ECO
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1. Change organizations to M1 Seattle Manufacturing
(N) INV Change Organization

2. Create two Items for your team (XX):
– Copy from AS10001 to make XX-10001
– Copy from CM65478 to make XX-65478

(N) ENG Prototypes > Items > Master Items (M)
Tools > Copy From

3. Assign your new items to M1 Seattle Manufacturing
(N) ENG Prototypes > Items > Master Items (M)
Tools > Organization Assignment

1. Change organizations to M1 Seattle Manufacturing
(N) INV Change Organization

2. Create two Items for your team (XX):
– Copy from AS10001 to make XX-10001
– Copy from CM65478 to make XX-65478

(N) ENG Prototypes > Items > Master Items (M)
Tools > Copy From

3. Assign your new items to M1 Seattle Manufacturing
(N) ENG Prototypes > Items > Master Items (M)
Tools > Organization Assignment
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4. Copy the Bill of Material from AS10001 to XX-10001
(N) ENG Prototypes > Bills > Bills (M) Tools > Copy
Bill from

5. Create an ECO as follows:
– ECO: XX-100
– Type: New Prod
– Approval Status: Approved

(N) ENG ECOs > ECOs
– Revised Item: XX-10001
– New Revision: B
– Effective Date: Four weeks from today

(N) ENG ECOs > ECOs (B) Revised Items

4. Copy the Bill of Material from AS10001 to XX-10001
(N) ENG Prototypes > Bills > Bills (M) Tools > Copy
Bill from

5. Create an ECO as follows:
– ECO: XX-100
– Type: New Prod
– Approval Status: Approved

(N) ENG ECOs > ECOs
– Revised Item: XX-10001
– New Revision: B
– Effective Date: Four weeks from today

(N) ENG ECOs > ECOs (B) Revised Items

Help: Oracle Manufacturing Applications > Oracle Engineering >
Engineering Change Orders > Defining an Engineering Change Order

… Engineering Change Orders > Defining ECO Revised Items
… Engineering Change Orders > Defining an ECO Revision
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5. Create an ECO continued:
– Disable Component: CM65478
– Add Component: XX-65478

(N) ENG ECOs > ECOs (B) Revised Items (B)
Components

6. Review the pending changes on your bill of
materials
Note: Remember to uncheck the Implemented Only
box before finding your bill
(N) ENG Prototypes > Bills > Indented Bills

5. Create an ECO continued:
– Disable Component: CM65478
– Add Component: XX-65478

(N) ENG ECOs > ECOs (B) Revised Items (B)
Components

6. Review the pending changes on your bill of
materials
Note: Remember to uncheck the Implemented Only
box before finding your bill
(N) ENG Prototypes > Bills > Indented Bills

Help: Oracle Manufacturing Applications > Oracle Engineering >
Engineering Change Orders > Defining Revised Components
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7. Review your new item revision for XX-10001:
(N) ENG Prototypes > Items > Organization Items
(M) Tools > Revisions

8. Compare the XX-10001 Current bill of material (Rev
A) with the pending bill (Rev B)
Note: Remember to uncheck both the Implemented
Only boxes
(N) ENG Prototypes > Bills > Comparison

9.  Review your pending ECO schedule
(N) ENG ECOs > Schedules

7. Review your new item revision for XX-10001:
(N) ENG Prototypes > Items > Organization Items
(M) Tools > Revisions

8. Compare the XX-10001 Current bill of material (Rev
A) with the pending bill (Rev B)
Note: Remember to uncheck both the Implemented
Only boxes
(N) ENG Prototypes > Bills > Comparison

9.  Review your pending ECO schedule
(N) ENG ECOs > Schedules

Help: Oracle Manufacturing Applications > Oracle Engineering >
Engineering Change Orders > Viewing Item Revisions
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10. Release the ECO
(N) ENG ECOs > ECOs (M) Tools > Release

11. Reschedule your ECO to one week earlier
(N) ENG ECOs > ECOs (M) Tools > Reschedule

12. Review the effect of the change to your pending
bill of material and revision
(N) ENG Prototypes > Bills > Indented Bills
(N) ENG ECOs > ECOs (B) Revised Items (B)
Revisions

10. Release the ECO
(N) ENG ECOs > ECOs (M) Tools > Release

11. Reschedule your ECO to one week earlier
(N) ENG ECOs > ECOs (M) Tools > Reschedule

12. Review the effect of the change to your pending
bill of material and revision
(N) ENG Prototypes > Bills > Indented Bills
(N) ENG ECOs > ECOs (B) Revised Items (B)
Revisions

Help: Oracle Manufacturing Applications > Oracle Engineering >
Engineering Change Orders > Changing ECO Status

… Engineering Change Orders > Viewing ECO Approval 
Status



Copyright © Oracle Corporation, 2000. All rights reserved.

R11i - Managing Engineering Change Orders
Chapter 1 - Page 42

Practice Solution

Copyright  Oracle Corporation, 2000. All rights reserved.
®

Practice SolutionPractice Solution

13. Manually implement your ECO
(N) ENG ECOs > ECOs (M) Tools > Implement

14. Review the bill of material to see the effect of
implementing the change
(N) ENG Prototypes > Bills > Indented Bills

15. Create another ECO as follows:
– ECO: XX-200
– Type: New Prod
– Priority: Standard

(N) ENG ECOs > ECOs

13. Manually implement your ECO
(N) ENG ECOs > ECOs (M) Tools > Implement

14. Review the bill of material to see the effect of
implementing the change
(N) ENG Prototypes > Bills > Indented Bills

15. Create another ECO as follows:
– ECO: XX-200
– Type: New Prod
– Priority: Standard

(N) ENG ECOs > ECOs

Help: Oracle Manufacturing Applications > Oracle Engineering >
Engineering Change Orders > Implementing ECOs
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15. Create another ECO continued:
– Revised Item: XX-10001
– New Revision: C
– Effective Date: Four weeks from today

(N) ENG ECOs > ECOs (B) Revised Items
16. Submit your new ECO to launch the workflow for

approval
 (N) ENG ECOs > ECOs (B) Submit

17. Approve your ECO
(N) ENG ECOs > Notification

15. Create another ECO continued:
– Revised Item: XX-10001
– New Revision: C
– Effective Date: Four weeks from today

(N) ENG ECOs > ECOs (B) Revised Items
16. Submit your new ECO to launch the workflow for

approval
 (N) ENG ECOs > ECOs (B) Submit

17. Approve your ECO
(N) ENG ECOs > Notification
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18. Review your ECO for Approval Status = Approved
and MRP Active = selected
 (N) ENG ECOs > ECOs (B) Revised Items

19. Manually implement your ECO
 (N) ENG ECOs > ECOs (M) Tools > Implement

18. Review your ECO for Approval Status = Approved
and MRP Active = selected
 (N) ENG ECOs > ECOs (B) Revised Items

19. Manually implement your ECO
 (N) ENG ECOs > ECOs (M) Tools > Implement


	R11i - Managing Engineering Change Orders
	R11i - Managing Engineering Change Orders
	Objectives
	Agenda
	Lesson 1: Overview of Engineering Change Orders
	Overview
	Engineering Change Orders
	Lesson 2: Engineering Change Order Life Cycle
	ECO Life Cycle
	ECO Statuses
	ECO Life Cycle - without Approval
	ECO Life Cycle without Approval
	ECO Life Cycle - with Approval
	ECO Approval: Oracle Engineering
	ECO Approval: Oracle Workflow
	Lesson 3: Engineering Change Order Business Objects Interface
	ECO Business Object Interface Overview
	ECO Business Object Interface
	Business Value of the ECO Object Interface
	Lesson 4: Summary
	Summary
	Lesson 4: Practice
	Practice Overview
	Practice Solution


